Content: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Background: Slate Blackcurrant Watermelon Strawberry Orange Banana Apple Emerald Chocolate Marble
Pattern: Blank Waves Notes Sharp Wood Rockface Leather Honey Vertical Triangles
Welcome to Xbox Chaos: Modding Evolved

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

GUSTER1337

General
Help me remove shield bar

4 posts in this topic

When i change the biped to a marine/grunt/jackal the shield bar glows red and shows warning, i want to remove it and only the health bar to remain can someone help me or point me to the right direction please.

Share this post


Link to post
Share on other sites

Under matg "global" you'll find a whole block that messes with your survivability with damage resistance, health multiplier, health recharge rate, shield recharge rate, and the fabled... Shield multiplier. Just set it to no shields (may have gotten the name wrong, can't check) 

GUSTER1337 likes this

Share this post


Link to post
Share on other sites

One down side to using the "no shields" setting is it disables shield powerups. So, for example, if you wanted to start with no shields and still be able to get them from a powerup, it's no go. When you get a shield powerup, the meter comes back briefly while the shields are charging up, then immediately disappears afterwards (along with the benefits of the shield).

Thus if you want to keep the shield meter in its empty state without the annoying warning sound effect and red flashing running the entire time, the quick and dirty method is:

1) Go into chgd - chud_globals_definition, scroll down to "HUD Sounds" and uncheck the box in #3 "shield depleted".

2) Go to chdt - chud definition, open spartan.chdt, and look for two different Animation Data boxes with references to "ui\chud\animations\shields_out" and change it to a less-annoying animation. On multiplayer maps, you can use "ui\chud\animations\boot_sequence\ping_boot" which is really the best option. On campaign maps, you can use "ui\chud\animations\fade_out" which still flashes the red warning exactly once, then goes away.

3) If using a compromise animation on campaign maps, you can also change the Warning text scale to 0 to get rid of it, and change Global Dynamic 5 to Global Dynamic 2 to reduce unwanted red/pink lines to blue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now